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Purpose of the Document

The purpose of this document is to explain the technical specifications and manual for using
the USB dongle board powered by STM32F072C8T6.

Document History

Version Author Date Description
A 5G HUB 14.01.2024 Initial Document
B 5G HUB 21.04.2024 Minor update in format
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1 Package contents:

1.1 STM32 USB Dongle Package:
e STM32F072C8T6 USB dongle.

1.2 Download

Install STM32CubeProgrammer for Windows.
https://www.st.com/en/development-tools/stm32cubeprog.html

Arduino software can be downloaded from the following website:
https://github.com/5ghub/stm32

To use the board with Arduino IDE and starts running Arduino projects and sketches, install the
following software:

Install Arduino IDE for Windows from the following web site
https://www.arduino.cc/en/Main/Software

Download and Install LTE&GNSS modem driver for Windows OS:
https://github.com/5ghub/5G-NB-loT/tree/master/Driver

Download and Install QNavigator and QCOM tools for Quectel BG95 here:
https://github.com/5ghub/5G-NB-loT/tree/master/Tools
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2 General Description

2.1 Overview

This is a USB dongle powered by STM32 MCU. The USB is designed as compact and complete development
platform for STMicroelectronics ARM cortex-MO core-based STM32F072C8T6 microcontroller with 12C,
SPI, USART, CAN, 12-bit ADC, 12-bit DAC, GP comparators, internal 16KB SRAM and 128KB Flash, USB FS,
Touch sensing, SWD debugging support.

The USB is used as a standalone board or used as a motherboard where other daughter boards can be
stacked on it. Daughter boards can be GNSS, Cellular, CAN transceiver, and other modules.

The USB leverages and utilizes all hardware features of STM32F072C8T6. The USB is designed for the
evaluation of all the peripherals and the development of user-specific applications. Extension headers are
used to easily connect a daughter board to it.

The USB board is a rich hardware board that can be used for the 4G LTE and GNSS wireless technology
and enables a variety of smart applications for devices. It enables large number of applications such as
wireless POS, smart metering, tracking, smart transportation, smart buildings, smart city, and smart
homes, CAN scanners, On-Board vehicle Diagnostics (OBD).

The board is also compatible with Arduino and Arduino software (IDE). Arduino sketches and examples
are provided with the kit and additional sketches can be developed and uploaded to the board.

2.2 Key Features

e STM32F072C8T6 MCU

e USB full-speed connector

e 5V USB power supply

e 12C, SPI, and UART interface

e CAN2.0A/B compliant interface

e SWD debug support

e Motherboard and daughter board switch button

e Extension connector for daughter board or wrapping board

e Analogue and Digital GPIOs

e Two user-programmable LEDs

e Compact board size of 59 mm x 25mm

e Arduino IDE Compatible

e  Works with Windows or Linux

e Ready for smart applications and development (smart home, smart city, smart transportation,
smart metering, smart farming, smart waste management, asset tracking, location, navigation,
mapping, and timing applications). Application such as Gas Detector, Soil PH Tester, Optical
Sensor, Machinery Alarm System, Irrigation Controller, Elevator, Asset Tracking Electronics,
Person/Pet Tracking, Water/Gas Metering, Smart Parking System, Fire Hydrant, Smoke Alarm,
Trash Bin, Street Lighting
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2.3 Overview Diagrams
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Figure 2. USB Modem Overview Diagram — Bottom View

2.4 Physical Characteristics
The width and length of the USB modem is 25 mm (width) by 59 mm (length). The board have two
screw holes in each corner that allows the board to be attached to a surface or case.
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Figure 3. Physical Characteristics.
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2.5 Peripherals — Key Components
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Figure 4. USB Modem Top Side — Key Components
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2.6 Hardware Specification

Technical Specification

Microcontroller (MCU)

STM32F072C8T6, 32-Bit ARM Cortex MO+

Clock Speed 48 MHz
Flash Memory 128 KB
SRAM 16 KB
NB-loT Module Quectel BG95-M?2 or BG95-M?2
Dimension 25 mm (width) by 60 mm (length)
Weight 20 grams
Power Supply USB (5V)
LED Power LED, LED1, LED2
Interfacing Logic Voltage Level
. 3.3V
(Operating Voltage)
Voltage output 5V, 3.3V

RESET buttons

Not Mounted

USB Switch

1 switch to connect to MCU directly or BG95 directly

General-purpose digital I/0
Pins

32 (PAO-PA15, PBO-PB15)

USB 1
12C 1
SPI 1
1 (with 1SO7816 interface, LIN, IrDA, auto baud rate detection and
UART
wakeup feature)
CAN 1
ADC pins 1 (12-bit ADC)
DAC pin 1 (12-bit DAC)
External interrupts 14 (All general-purpose PINs)
PWM pin 6
DC Current per I/0 Pin 10 mA
JTAG Debug Cortex Debug Connector (Single Wire Debug)

USB STM32 Rev 1.0
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2.7 PIN Description

PIN DIRECTION Description
USB Connector I The USB modem is powered from the USB port (3.8V-5V)
LED which can be controlled from MCU (D25). When the pin is
LED1 {USER) 0 HIGH value, the LED is on, when the pinis LOW, it is off
LED which can be controlled from MCU (D26). When the pin is
LED2 (USER) 0 HIGH value, the LED is on, when the pinis LOW, it is off
USB Switch I 1 switch to connect to MCU directly or BG95 directly
3.3V generated by the on-board regulator. Maximum current
3.3V 0 drawn is 3A. The regulator also provides power to the MCU and
BG95
5V generated from the board. The board is supplied with power
5v 0] .
from USB connector (typical 5V)
GND Ground
PA5_AIN5 10
PA6_AIN5 10 . . . . . .
= Six analog inputs which can provide up to 12 bits of resolution
PA7_AIN5 10 . . .
= (i.e. 4096 different values). By default, each input measures
PBO_AIN9 10
= from ground to 3.3 volts.
PB1_AIN9 10
SCL 10
SDA 10 I2C. The SCL (clock line). Can be used as GPIO
SCK 10 I2C. The SDA (data line). Can be used as GPIO
MISO 10 SPI Interface. Can be used as GPIO
MOSI 10 SPI Interface. Can be used as GPIO
SS 10 SPI Interface. Can be used as GPIO
CAN Tx/Rx 10 CAN Interface. Can be used as GPIO
PA8/ PA9/ PA10 10 GPIO
Cortex Debug 10 GPIO. Can be used as GPIO
Connector
BOOTO | Using Single Wire Debug to burn bootloader and debug the
board
Connected to BG95. Force the BG95 to enter emergency download
mode
Precaution

The USB modem runs at 3.3V. The maximum voltage that the 1/0 pins can tolerate is 3.3V.
Applying voltages higher than 3.3V to any I/0 pin could damage the board

USB STM32 Rev 1.0
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3 Using the Board with Arduino IDE
3.1 Installing the Software

To use the board with Arduino IDE and starts running Arduino projects and sketches, install the
following software:

3.2 Setting Up the Board
Gently move the switch S1 left or right to make the USB port either connect to Motherboard (STM32) or

daughter board.
/Daughter /-Mother
" board " board

-
-

>

@
©
~
-
=
=
w

@

3.3 Setting Up STM32 Bootloader

Make sure to install STM32CubeProgammer. Do the following:

1- Connect a shunt into PIN4 and PIN3 on J4
2- Insert the USB dongle into USB port on a PC.
3- Launch windows device manager, and you shall see the STM32 bootloader.
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4- Launch the STM32CubeProgammer, select SUB, and click Connect. You shall see the STM32F072

connected.

iy Device Manager — O
File Action View Help

o= HE R B EX®

X

» % Batteries

il Biometric devices

0 Bluetooth

® Cameras

EH Computer

- Lisk drives

L& Display adapters

B Firmware

Human Interface Devices

-i% Imaging devices

I? Junge Ceonnectivity
Keyboards

L I Memory technology devices
B Mice and other pointing devices
3 Monitors

I Metwork adapters

f§ Ports (COM & LPT)

= Print queues

= Printers

[ Processors

07 Security devices

[ Sensors

lt Software components

B Software devices

I Sound, video and game controllers
&y Storage controllers

i3 System devices

i Universal Serial Bus controllers

'{VVVVVVVVVVVVVVVVVVVVVVVVVVV

i Universal Serial Bus devices
§ Billboard Device
i Camera DFU Device
§ STM32 BOOTLOADER
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STM32CubeProgrammer - [m] X

Memory & File editing

Device memory | O

Address | 0x08000000 | ¥ | Size | 0x400 Datawidth | 32-bit v | Find Data 0x

Address 0 4 8 c AsCll

0x08000000 FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF VYYYYYYYYYYYYYYY
0x08000010 FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF VYTV
0x08000020 FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF VYYYIYYYYYYYYYYY
0x08000030 FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF VYISV
0x08000040 FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF VYVYYYIYYYYIYyYY
0x08000050 FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF VYYYYYYYYVYYYYYY
0x08000060 FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF VYVIYYIVYIYIYY
0x08000070 FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF VYYYYYYYYVYYYYYY
0x08000080 FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF VYVIYYIVYIYIYY
0x08000080 FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF VYYYYYYYYVYYYYYY
0x080000A0 FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF VYTV
0x080000B0 FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF VYYYYYYYYVYYYYYY
0x080000C0 FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF % %%
0x080000D0 FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF YYYYVYYYYVYYYIYY

Log Live Update  Verbosity level (@) 1 2

08:18:06 : STM32CubeProgrammer AP| v2.13.0 | Windows-64Bits
UR connection mode is defined with the HWrst reset mode
USB speed : Full Speed (12M8it/s)
Manuf. 1D : STMicroelectronics
+Product ID : STM32 BOOTLOADER
SN i FFFFFFFEFFFF

DFU protecok 1.1

Board -
i Device ID : 0x0448
UPLOADING OPTION BYTES DATA..

Bank  :0x0D

Address 01800
i Size  116Bytes
UPLOADING ...

Size  :1024 Bytes

Address 1 0x8000000
i Read progress:

08:18:37 : Time elapsed during the read operation is: 00:00:00.024

3.4 Setting Up Arduino IDE
1- Launch Arduino IDE and choose File->Preferences. In the Additional Boards Manager URLs,
insert the following URL:

https://github.com/stm32duino/BoardManagerFiles/raw/main/package stmicroelectronics in
dex.json

USB STM32 Rev 1.0 Copyright © 5GHUB.US
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& 3Ghub_bmeBB0async | Arduino IDE 2.1.1
File Edit Sketch Tools Help

2- In Arduino IDE, choose Tools->Board->Boards Manager, select and install “STM32F072C8T6

Board”.

3- Choose “STM32F072C8T6”

STM32F072C8T6 -
5Ghub_bmeB&async.ino
22 #include <STM32_board.h>
23
24 #define SEALEVELPRESSURE_HPA (1813.25)
25
26 // Using I2C Interface
27 _5GHUB_BMEG38 bme;
2 : Preferences P
20 void setup()
38 {
31 Wire.setSDA(PB11);
32 Wire.setSCL(PB10);
33 Sketchbook location
34 serial.begin(115200); o saDocum m
E while (Serial.read() >= 8
36 Serial.println(F("BMEGS® | 14
s e e in()) Interface scale B Avomatic 100 %
39 { Theme v
a0 Serial.println(F("BMEGS | .. g0 ~ | (Reload required)
41 while (1); _
b ) Show verbose output during 3 compile (J upload
43 Compiler wamings v
as // Configure BMEG68® overs| [ Verify code after upload
45 bme.SetTemperatureOversam| 1% Auto sav:
46 bme . SetHumidityOversampli| 4 Editor Quick Suggestions
o DS .SELRFESSUPSOVERSAMPIY 15001 boards manager URLs: hitps 0/BoardMa
48 bme.SetIIRFilterSize(BME6!
49 bme.SetGasHeater (328, 150
sa  }
51
52 void loop() L F
G «

STM32F072C8T6 [not connected]

USB STM32 Rev 1.0 Copyright © 5GHUB.US
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& 5Ghub_bmeb80async | Arduino IDE 2.1.1
File Edit Sketch Tools Help
Auto Format

Archive Sketch

Burn Bootloader

. Manage Libraries..
22 Serial Monitor
23 )
n Serial Plotter
25 -
e WIFIOT / WiFININA Firmuware Updater
27 Upload S5L Root Certificates
28 eTMIIEITICATE
. Board: "STM32F072C8T6
D) Fort
3 Get Board Info
3
3 Debug symols and core logs: "None”
3 Optimize: "Smallest (-Os default)”
- Board part number: *STM32F072C8TE"
3
3 € Runtime Library: "Newlia Nano (default)”
3 Upload method: "STM32CubeProgramm: )
3 USB support (if available): "CDC (generic ‘Serial’ supersede U(S)ART)"
a¢

» Boards Managsr..

3G-NEB-loT SAMD Board (32-bits ARM Cortex-MO0+)

Adafruit nRF52
Arduino AVR Boards
Arduino nRF52 Boards
ATtiny Microcontrellers

ATTinyCore

STM32F072C8T6 Board

Teensy

IMXRT1062 (NXP 32-bits ARM Cortex-M7) Boards

Qutput

(BMEGB@_0S_2X);
g(BMEGB8_OS,

v STM32F072C8T6

Ln4,Col 1 STM32FO72CETS [not connected]

4- In the Arduino IDE, Choose Sketch->Include Library->Add .Zip Library and select the file

STM32_Arduino.zip

5- You are ready now to use the Arduino IDE and write the first sketch. You can start compiling

Arduino sketches and upload the sketch to the USB dongle.

6- When uploading an Arduino sketch, make sure the following setting are selected:

Board: "STM32F072C8Te"
Port: "COM3"

Get Board Info

Debug symbols and core logs: "Nona"
Cptimize: "Smallest (-Os default)”
Board part number: "STM32F072C8TE"

C Runtime Library: "Mewlib Nano (default)”

Upload method: "STM32CubeProgrammer (DFU)

USB suppart (if available): "CDC (generic 'Serial’ supersede U(S)ART)"

Burn Bootloader

7- After uploading an Arduino sketch, unplug the shunt, and re-insert the USB dongle again into
the USB port. Windows will recognize the USB dongle as a new COM port as show here:

USB STM32 Rev 1.0
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iy Device Manager — O ot
File Action View Help

&= | F|E HE B EX®

v % LAPTOP-HOSSAMMNEW
3 i.q Audic inputs and cutputs
] % Batteries
» & Biometric devices
v 9 Bluetooth
@. Intel(R) Wireless Bluetooth(R)
] @' Cameras
> B Computer
b s sk drives
» @ Display adapters
] i Firmware
5 Human Interface Devices
> o3 Imaging devices
> I Jungo Connectivity
» Keyboards
» L1 Memory technology devices
5 B Mice and other pointing devices
» [ Menitors
» I? Metwork adapters
v & Ports (COM &LPT)
ﬁ Intel(R) Active Management Technology
ﬁ USE Serial Device (COM3)
» =1 Print queues
» ™ Printers

8- In Arduino IDE, choose Port->COMS5.
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[oo] User_LED | Arduine IDE 2,11
File Edit Sketch Tools Help

Auto Format Ctrl+T
Archive Sketch

User_LET Manage Libraries... Ctrl+Shift+|

1 Serial Monitor Ctrl+ Shift =

2

. Serial Plotter

3

: WIFi101 / WiFININA Firmware Updater

5 Upload S5L Root Certificates

; Board: "STM32F072CETE" »

g Port: "COMS3" » Serial ports
1@ Get Board Info COmM3
1 COMS
12 Debug symbels and core logs: "None” [

13 Optimize: "Smallest (-Os default)” r

i: Board part number: "STM32F072C8TE" » N
16 C Runtime Library: "Mewlib Mano (default)" 3 .
17 Upload method: "STM32CubePragrammer (DFU)" »

13 USB support (if available): "CDC (generic "Senial’ supersede U[S)ART)" 2

19

28 Burn Bootloader

21 PINMMOOEPETS; UUTPOT S

22 pinMode(PB14,0UTPUT);

23 H

24

25 void loop()

26 {

Now, you can enable Arduino IDE Serial Monitor and see the Arduino sketch running on the board.

NOTE:
When uploading Arduino sketch to the USB dongle, a shunt must be connected between PIN4 and
PIN3 of J4 (i.e, the STM32 MCU must be in BOOT mode)

NOTE:
To run the Arduino sketch, unplug the shunt and re-insert the USB dongle into a USB port again.

USB STM32 Rev 1.0 Copyright © 5GHUB.US



https://5ghub.us/

	Purpose of the Document
	Document History
	1 Package contents:
	1.1 STM32 USB Dongle Package:
	1.2 Download

	2 General Description
	2.1 Overview
	2.2 Key Features
	2.3 Overview Diagrams
	2.4 Physical Characteristics
	2.5 Peripherals – Key Components
	2.6 Hardware Specification
	2.7 PIN Description

	3 Using the Board with Arduino IDE
	3.1 Installing the Software
	3.2 Setting Up the Board
	3.3 Setting Up STM32 Bootloader
	3.4 Setting Up Arduino IDE


